Temporary payment issue
Incident Report for MATCHi AB
Resolved
This incident has been resolved.
Posted May 15, 2020 - 13:07 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2020 - 12:58 CEST
Investigating
We’re currently experiencing a temporary issue with payments made through MATCHi. Our tech team is working hard to resolve the issue. We'll update our status page continuously.
Posted May 15, 2020 - 12:55 CEST
This incident affected: Payments.