Payment provider under DDOS attack

Incident Report for MATCHi AB

Resolved

Our payment provider has restored services
Posted Apr 21, 2025 - 21:46 CEST

Update

We are continuing to investigate this issue.
Posted Apr 21, 2025 - 21:09 CEST

Investigating

Our payment provider Adyen is under a DDOS attack which is degrading the performance of our payments.
Posted Apr 21, 2025 - 19:39 CEST
This incident affected: Payments.