Performance and Maintenance
Incident Report for MATCHi AB
Resolved
This incident has been resolved.
Posted Jan 29, 2020 - 00:00 CET
Update
Maintenance work on Web application is now done.
Both the Web and Mobile application is now fully operational.
Posted Jan 28, 2020 - 10:19 CET
Update
Mobile application temporarily affected. Will update when back to normal.
Posted Jan 28, 2020 - 10:10 CET
Update
We're now distributing traffic between multiple server instances. Availability or connectivity may be affected.
Posted Jan 28, 2020 - 09:44 CET
Update
Still undergoing maintenance work
No disruptions as of yet. Will update continuously.
Posted Jan 28, 2020 - 09:19 CET
Update
Undergoing maintenance work
During the upcoming hour we're working on improving our server infrastructure to help with recent traffic spikes on the Web application. This might result in short periods of disruptions - no longer than a few minutes at a time. Will update continuously.
Posted Jan 28, 2020 - 08:54 CET
Update
The issue that caused the longer outage previously today is now solved. Both the Web and Mobile application is now operational. We've implemented several performance improvements and will continue to monitor the situation closely.
Posted Jan 27, 2020 - 16:30 CET
Monitoring
One possible solution identified. Testing on Web application. New version just released. Mobile application disabled while monitoring.
Posted Jan 27, 2020 - 16:16 CET
Update
Serious outage. Still investigating. Mobile application now working again.
Posted Jan 27, 2020 - 15:51 CET
Update
We are continuing to investigate this issue.
Posted Jan 27, 2020 - 15:11 CET
Investigating
Longer downtime than expected impacting most users and admins. Still haven't identified the issue. The mobile application is now also impacted.
Posted Jan 27, 2020 - 15:08 CET
Update
Still working on solving the issue from earlier today. The app is still up and running.
Posted Jan 27, 2020 - 14:25 CET
Update
Experiencing issues with necessary maintenance work. We’re working as fast as we can to resolve the issue and will update our status page as soon as there’s any changes in status. Note that our mobile application is still currently up and running.
Posted Jan 27, 2020 - 13:33 CET
Monitoring
The issue from a few minutes ago is solved.
We're currently undergoing maintenance of the web application to improve performance while investigating recent stability issues. This may result in the service being unavailable for shorter period of times for the coming weeks (as far as possible not during peak hours, but sometimes unavoidable).
Posted Jan 24, 2020 - 07:56 CET
Identified
Issue this morning with an upgrade that is being reverted. Longer downtime than expected impacting most users and admins.
Posted Jan 24, 2020 - 07:49 CET
Monitoring
The issue from a few minutes ago is solved.
We're currently undergoing maintenance of the web application to improve performance while investigating recent stability issues. This may result in the service being unavailable for shorter period of times for the coming weeks (as far as possible not during peak hours, but sometimes unavoidable).
Posted Jan 20, 2020 - 12:36 CET
Update
Issue with web application & investigation ongoing. Mobile applications on Android and iOS are working.
Posted Jan 20, 2020 - 12:30 CET
Investigating
We're currently undergoing maintenance of the web application to improve performance while investigating recent stability issues. This may result in the service being unavailable for shorter period of times for the coming weeks (as far as possible not during peak hours, but sometimes unavoidable).
Posted Jan 20, 2020 - 12:16 CET
Monitoring
Two issues identified, fixed and released:

* mobile app: reduced number of requests needed to server (new version is 20.1.4). We will try to enforce that all users update to this version at 10pm (22:00) tonight.

* an underlying performance issue was how our JVM was handling specific memory operations. There was a fix for this yesterday evening.


One performance optimisation released:
* New server instance to handle heavy operations and scheduled jobs


We now monitor the fixes while working on further optimisations.
Posted Jan 16, 2020 - 17:11 CET
Investigating
We're currently undergoing maintenance of the Web application to improve performance. This may result in the service being unavailable for shorter period of times. At the same time, we're investigating recent stability issues.

If you're a MATCHi administrator:
We might need to switch off specific features at given times. We'll send out specific notifications in advance in case we turn off a feature. Thank you for your patience.
Posted Jan 15, 2020 - 16:20 CET
This incident affected: Web application, iOS application, and Android application.